package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:(\w+) )?order to (\w+) ([\-\d\.]+) (\w+) at ([\-\d\.]+|market) with ExDestination to (\w+) gets( fully| over)? filled(?: again)? (?:for ([\-\d\.]+)(?: contracts | shares )?)?at ([\-\d\.]+|market)`)
var str = `order to SELL 5 AAPL at market with ExDestination to ANY gets fully filled at market`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}