# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:@delim)+//g;t' <<< "@delimabc@delim@delim123@delim@delim456@delim"