re = /(?:@delim)+/
str = '@delimabc@delim@delim123@delim@delim456@delim'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result