$re = '/(?:@delim)+/';
$str = '@delimabc@delim@delim123@delim@delim456@delim';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;