use strict;
my $str = '@delimabc@delim@delim123@delim@delim456@delim';
my $regex = qr/(?:@delim)+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";