import Foundation
let pattern = #"(?:@delim)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"@delimabc@delim@delim123@delim@delim456@delim"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)