package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:@delim)+`)
var str = `@delimabc@delim@delim123@delim@delim456@delim`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}