# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(Madame|Mademoiselle|Mlle|Me|Monsieur|Mme|M|né|née)\b(\s+[A-Z](\w|[éèïùêâô])+)+/$1 Camille Lepoix/gm;t' <<< "Je revois ce soir Mme Lepautre Agnès en consultation"