package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(Madame|Mademoiselle|Mlle|Me|Monsieur|Mme|M|né|née)\b(\s+[A-Z](\w|[éèïùêâô])+)+`)
var str = `Je revois ce soir Mme Lepautre Agnès en consultation`
var substitution = "$1 Camille Lepoix"
fmt.Println(re.ReplaceAllString(str, substitution))
}