#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(Madame|Mademoiselle|Mlle|Me|Monsieur|Mme|M|né|née)\b(\s+[A-Z](\w|[éèïùêâô])+)+"
Local $sString = "Je revois ce soir Mme Lepautre Agnès en consultation"
Local $sSubst = "$1 Camille Lepoix"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)