import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(Madame|Mademoiselle|Mlle|Me|Monsieur|Mme|M|né|née)\\b(\\s+[A-Z](\\w|[éèïùêâô])+)+";
final String string = "Je revois ce soir Mme Lepautre Agnès en consultation";
final String subst = "$1 Camille Lepoix";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}