$re = '/\b(Madame|Mademoiselle|Mlle|Me|Monsieur|Mme|M|né|née)\b(\s+[A-Z](\w|[éèïùêâô])+)+/m';
$str = 'Je revois ce soir Mme Lepautre Agnès en consultation';
$subst = "$1 Camille Lepoix";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;