const regex = /\b(Madame|Mademoiselle|Mlle|Me|Monsieur|Mme|M|né|née)\b(\s+[A-Z](\w|[éèïùêâô])+)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(Madame|Mademoiselle|Mlle|Me|Monsieur|Mme|M|né|née)\\b(\\s+[A-Z](\\w|[éèïùêâô])+)+', 'gm')
const str = `Je revois ce soir Mme Lepautre Agnès en consultation`;
const subst = `$1 Camille Lepoix`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);