using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(code|php|html)](.*?)\[/\\1](*SKIP)(*F)|\[quote(\]|(=.*?)\]|(\s.*?)\])(.*?)\[\/quote\]";
string input = @"[quote=144][quote=142]fddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddd MOBİLE UYGUN OLMAYAN YAZI dsssssssssssssssssssssss
what has changed?
[/quote]
Burayla ne alakası var URL kısaltıcının parçası o.[/quote]
deneme";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}