import Foundation
let pattern = #"\[(code|php|html)](.*?)\[/\\1](*SKIP)(*F)|\[quote(\]|(=.*?)\]|(\s.*?)\])(.*?)\[\/quote\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
[quote=144][quote=142]fddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddd MOBİLE UYGUN OLMAYAN YAZI dsssssssssssssssssssssss
what has changed?
[/quote]
Burayla ne alakası var URL kısaltıcının parçası o.[/quote]
deneme
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}