import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(code|php|html)](.*?)\\[/\\\\1](*SKIP)(*F)|\\[quote(\\]|(=.*?)\\]|(\\s.*?)\\])(.*?)\\[\\/quote\\]";
final String string = "[quote=144][quote=142]fddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddd MOBİLE UYGUN OLMAYAN YAZI dsssssssssssssssssssssss\n\n"
+ "what has changed?\n"
+ "[/quote]\n"
+ "Burayla ne alakası var URL kısaltıcının parçası o.[/quote]\n"
+ "deneme";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}