import re
regex = re.compile(r"\[(code|php|html)](.*?)\[/\\1](*SKIP)(*F)|\[quote(\]|(=.*?)\]|(\s.*?)\])(.*?)\[\/quote\]", flags=re.DOTALL | re.IGNORECASE)
test_str = ("[quote=144][quote=142]fddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddd MOBİLE UYGUN OLMAYAN YAZI dsssssssssssssssssssssss\n\n"
"what has changed?\n"
"[/quote]\n"
"Burayla ne alakası var URL kısaltıcının parçası o.[/quote]\n"
"deneme")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")