$re = '~\[(code|php|html)](.*?)\[/\\\\1](*SKIP)(*F)|\[quote(\]|(=.*?)\]|(\s.*?)\])(.*?)\[\/quote\]~si';
$str = '[quote=144][quote=142]fddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddddd MOBİLE UYGUN OLMAYAN YAZI dsssssssssssssssssssssss
what has changed?
[/quote]
Burayla ne alakası var URL kısaltıcının parçası o.[/quote]
deneme';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);