package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^([sS][mM][bB]\:\/\/(?:(?:[^@\\\/]+(?:\:[^@]+@)[^@\\\/\?]+)|(?:[^\\\/?]+)))\/([^\\\/]+)(?:[\\\/]([^?\:]*))?$)`)
var str = `smb://server;user:\pas/sw\ord@1.1.1:56/share/d/r/r
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}