$re = '/(?:^([sS][mM][bB]\:\/\/(?:(?:[^@\\\\\/]+(?:\:[^@]+@)[^@\\\\\/\?]+)|(?:[^\\\\\/?]+)))\/([^\\\\\/]+)(?:[\\\\\/]([^?\:]*))?$)/m';
$str = 'smb://server;user:\\pas/sw\\ord@1.1.1:56/share/d/r/r
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);