const regex = new RegExp('(?:^([sS][mM][bB]\\:\\/\\/(?:(?:[^@\\\\\\/]+(?:\\:[^@]+@)[^@\\\\\\/\\?]+)|(?:[^\\\\\\/?]+)))\\/([^\\\\\\/]+)(?:[\\\\\\/]([^?\\:]*))?$)', 'gm')
const str = `smb://server;user:\\pas/sw\\ord@1.1.1:56/share/d/r/r
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}