import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^([sS][mM][bB]\\:\\/\\/(?:(?:[^@\\\\\\/]+(?:\\:[^@]+@)[^@\\\\\\/\\?]+)|(?:[^\\\\\\/?]+)))\\/([^\\\\\\/]+)(?:[\\\\\\/]([^?\\:]*))?$)";
final String string = "smb://server;user:\\pas/sw\\ord@1.1.1:56/share/d/r/r\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}