#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"(((?<!\\)(\\\\)*\\"|[^"])*)""
Local $sString = ""Woah. Look. A tab."" & @CRLF & _
""This \\\\\\\\\\\\\" is all one string"" & @CRLF & _
""This \"\"\"\" is\" also\"\\ \' one\"\\\" string."" & @CRLF & _
""These \\""are separate strings"" & @CRLF & _
""The cat said,\"Yo.\""" & @CRLF & _
""" & @CRLF & _
"\"Shouldn't it work on multiple lines?\" he asked rhetorically." & @CRLF & _
"\"Of course it should.\"" & @CRLF & _
""" & @CRLF & _
""If you don't have exactly 8 matches, then you've failed."" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")