import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(((?<!\\\\)(\\\\\\\\)*\\\\\"|[^\"])*)\"";
final String string = "\"Woah. Look. A tab.\"\n"
+ "\"This \\\\\\\\\\\\\\\\\\\\\\\\\\\" is all one string\"\n"
+ "\"This \\\"\\\"\\\"\\\" is\\\" also\\\"\\\\ \\' one\\\"\\\\\\\" string.\"\n"
+ "\"These \\\\\"\"are separate strings\"\n"
+ "\"The cat said,\\\"Yo.\\\"\"\n"
+ "\"\n"
+ "\\\"Shouldn't it work on multiple lines?\\\" he asked rhetorically.\n"
+ "\\\"Of course it should.\\\"\n"
+ "\"\n"
+ "\"If you don't have exactly 8 matches, then you've failed.\"\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}