re = /"(((?<!\\)(\\\\)*\\"|[^"])*)"/m
str = '"Woah. Look. A tab."
"This \\\\\\\\\\\\\\\\\\\\\\\\\\" is all one string"
"This \\"\\"\\"\\" is\\" also\\"\\\\ \\\' one\\"\\\\\\" string."
"These \\\\""are separate strings"
"The cat said,\\"Yo.\\""
"
\\"Shouldn\'t it work on multiple lines?\\" he asked rhetorically.
\\"Of course it should.\\"
"
"If you don\'t have exactly 8 matches, then you\'ve failed."
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end