using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(((?<!\\)(\\\\)*\\""|[^""])*)""";
string input = @"""Woah. Look. A tab.""
""This \\\\\\\\\\\\\"" is all one string""
""This \""\""\""\"" is\"" also\""\\ \' one\""\\\"" string.""
""These \\""are separate strings""
""The cat said,\""Yo.\""
""
\""Shouldn't it work on multiple lines?\"" he asked rhetorically.
\""Of course it should.\""
""
""If you don't have exactly 8 matches, then you've failed.""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}