const regex = /"(((?<!\\)(\\\\)*\\"|[^"])*)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(((?<!\\\\)(\\\\\\\\)*\\\\"|[^"])*)"', 'gm')
const str = `"Woah. Look. A tab."
"This \\\\\\\\\\\\\\\\\\\\\\\\\\" is all one string"
"This \\"\\"\\"\\" is\\" also\\"\\\\ \\' one\\"\\\\\\" string."
"These \\\\""are separate strings"
"The cat said,\\"Yo.\\""
"
\\"Shouldn't it work on multiple lines?\\" he asked rhetorically.
\\"Of course it should.\\"
"
"If you don't have exactly 8 matches, then you've failed."
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}