use strict;
my $str = '"Woah. Look. A tab."
"This \\\\\\\\\\\\\\\\\\\\\\\\\\" is all one string"
"This \\"\\"\\"\\" is\\" also\\"\\\\ \\\' one\\"\\\\\\" string."
"These \\\\""are separate strings"
"The cat said,\\"Yo.\\""
"
\\"Shouldn\'t it work on multiple lines?\\" he asked rhetorically.
\\"Of course it should.\\"
"
"If you don\'t have exactly 8 matches, then you\'ve failed."
';
my $regex = qr/"(((?<!\\)(\\\\)*\\"|[^"])*)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}