using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\/<!-)([^\/]*(?:\/(?!\/!>)[^\/]*)*)(\/\/!>)";
string input = @"//<!- directiveDecoratorComment
(function directiveDecorator() {
if (typeof(angular) == 'undefined') return;
var appElement = document.querySelector('[ng-app]');
var appName = appElement.getAttribute('ng-app');
if (typeof(appName) == 'undefined') return;
var app = angular.module(appName);
angular.forEach(app._invokeQueue, function(value, key) {
if (value[1] == 'directive') {
var directiveName = value[2][0];
app.config(function($provide) {
$provide.decorator(directiveName + 'Directive', function($delegate) {
var directive = $delegate[0];
console.log(""Decorating:"",directiveName,'on',appName,'template now ==',""/views/"" + directive.templateUrl);
directive.templateUrl = ""/views/"" + directive.templateUrl;
return $delegate;
});
});
}
});
}());
//!>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}