# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/\/<!-)([^\/]*(?:\/(?!\/!>)[^\/]*)*)(\/\/!>)"
test_str = ("//<!- directiveDecoratorComment\n"
" (function directiveDecorator() {\n"
" if (typeof(angular) == 'undefined') return;\n"
" var appElement = document.querySelector('[ng-app]');\n"
" var appName = appElement.getAttribute('ng-app');\n"
" if (typeof(appName) == 'undefined') return;\n"
" var app = angular.module(appName);\n"
" angular.forEach(app._invokeQueue, function(value, key) {\n"
" if (value[1] == 'directive') {\n"
" var directiveName = value[2][0];\n"
" app.config(function($provide) {\n"
" $provide.decorator(directiveName + 'Directive', function($delegate) {\n"
" var directive = $delegate[0];\n"
" console.log(\"Decorating:\",directiveName,'on',appName,'template now ==',\"/views/\" + directive.templateUrl);\n"
" directive.templateUrl = \"/views/\" + directive.templateUrl;\n"
" return $delegate;\n"
" });\n"
" });\n"
" }\n"
" });\n"
" }());\n\n"
" //!>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.