import Foundation
let pattern = #"(\/\/<!-)([^\/]*(?:\/(?!\/!>)[^\/]*)*)(\/\/!>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
//<!- directiveDecoratorComment
(function directiveDecorator() {
if (typeof(angular) == 'undefined') return;
var appElement = document.querySelector('[ng-app]');
var appName = appElement.getAttribute('ng-app');
if (typeof(appName) == 'undefined') return;
var app = angular.module(appName);
angular.forEach(app._invokeQueue, function(value, key) {
if (value[1] == 'directive') {
var directiveName = value[2][0];
app.config(function($provide) {
$provide.decorator(directiveName + 'Directive', function($delegate) {
var directive = $delegate[0];
console.log("Decorating:",directiveName,'on',appName,'template now ==',"/views/" + directive.templateUrl);
directive.templateUrl = "/views/" + directive.templateUrl;
return $delegate;
});
});
}
});
}());
//!>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}