re = /(\/\/<!-)([^\/]*(?:\/(?!\/!>)[^\/]*)*)(\/\/!>)/
str = '//<!- directiveDecoratorComment
(function directiveDecorator() {
if (typeof(angular) == \'undefined\') return;
var appElement = document.querySelector(\'[ng-app]\');
var appName = appElement.getAttribute(\'ng-app\');
if (typeof(appName) == \'undefined\') return;
var app = angular.module(appName);
angular.forEach(app._invokeQueue, function(value, key) {
if (value[1] == \'directive\') {
var directiveName = value[2][0];
app.config(function($provide) {
$provide.decorator(directiveName + \'Directive\', function($delegate) {
var directive = $delegate[0];
console.log("Decorating:",directiveName,\'on\',appName,\'template now ==\',"/views/" + directive.templateUrl);
directive.templateUrl = "/views/" + directive.templateUrl;
return $delegate;
});
});
}
});
}());
//!>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end