import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\/<!-)([^\\/]*(?:\\/(?!\\/!>)[^\\/]*)*)(\\/\\/!>)";
final String string = "//<!- directiveDecoratorComment\n"
+ " (function directiveDecorator() {\n"
+ " if (typeof(angular) == 'undefined') return;\n"
+ " var appElement = document.querySelector('[ng-app]');\n"
+ " var appName = appElement.getAttribute('ng-app');\n"
+ " if (typeof(appName) == 'undefined') return;\n"
+ " var app = angular.module(appName);\n"
+ " angular.forEach(app._invokeQueue, function(value, key) {\n"
+ " if (value[1] == 'directive') {\n"
+ " var directiveName = value[2][0];\n"
+ " app.config(function($provide) {\n"
+ " $provide.decorator(directiveName + 'Directive', function($delegate) {\n"
+ " var directive = $delegate[0];\n"
+ " console.log(\"Decorating:\",directiveName,'on',appName,'template now ==',\"/views/\" + directive.templateUrl);\n"
+ " directive.templateUrl = \"/views/\" + directive.templateUrl;\n"
+ " return $delegate;\n"
+ " });\n"
+ " });\n"
+ " }\n"
+ " });\n"
+ " }());\n\n"
+ " //!>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}