const regex = /(\/\/<!-)([^\/]*(?:\/(?!\/!>)[^\/]*)*)(\/\/!>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\\/<!-)([^\\\/]*(?:\\\/(?!\\\/!>)[^\\\/]*)*)(\\\/\\\/!>)', '')
const str = `//<!- directiveDecoratorComment
(function directiveDecorator() {
if (typeof(angular) == 'undefined') return;
var appElement = document.querySelector('[ng-app]');
var appName = appElement.getAttribute('ng-app');
if (typeof(appName) == 'undefined') return;
var app = angular.module(appName);
angular.forEach(app._invokeQueue, function(value, key) {
if (value[1] == 'directive') {
var directiveName = value[2][0];
app.config(function(\$provide) {
\$provide.decorator(directiveName + 'Directive', function(\$delegate) {
var directive = \$delegate[0];
console.log("Decorating:",directiveName,'on',appName,'template now ==',"/views/" + directive.templateUrl);
directive.templateUrl = "/views/" + directive.templateUrl;
return \$delegate;
});
});
}
});
}());
//!>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}