# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(#table\d+)|\((\w{1,2})(\))/$2/g;t' <<< "<p id=\"para\"> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo<a href=\"#table1(t1)\" id=\"ytD2F\">table1</a> test demo test demo test demo test demo test demo <a href=\"#table2(t2)\" id=\"ytD2F\">table2</a> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test </p>"