import Foundation
let pattern = ##"(#table\d+)|\((\w{1,2})(\))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"<p id="para"> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo<a href="#table1(t1)" id="ytD2F">table1</a> test demo test demo test demo test demo test demo <a href="#table2(t2)" id="ytD2F">table2</a> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test </p>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)