// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(#table\d+)|\((\w{1,2})(\))").unwrap();
  let string = "<p id=\"para\"> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo<a href=\"#table1(t1)\" id=\"ytD2F\">table1</a> test demo test demo test demo test demo test demo <a href=\"#table2(t2)\" id=\"ytD2F\">table2</a> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test </p>";
  let substitution = "$2";
  
  // result will be a String with the substituted value
  let result = regex.replace_all(string, substitution);
  
  println!("{}", result);
}