using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#table\d+)|\((\w{1,2})(\))";
string substitution = @"$2";
string input = @"<p id=""para""> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo<a href=""#table1(t1)"" id=""ytD2F"">table1</a> test demo test demo test demo test demo test demo <a href=""#table2(t2)"" id=""ytD2F"">table2</a> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test </p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}