import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(#table\\d+)|\\((\\w{1,2})(\\))";
final String string = "<p id=\"para\"> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo<a href=\"#table1(t1)\" id=\"ytD2F\">table1</a> test demo test demo test demo test demo test demo <a href=\"#table2(t2)\" id=\"ytD2F\">table2</a> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test </p>";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}