# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(#table\d+)|\((\w{1,2})(\))"
test_str = "<p id=\"para\"> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test demo<a href=\"#table1(t1)\" id=\"ytD2F\">table1</a> test demo test demo test demo test demo test demo <a href=\"#table2(t2)\" id=\"ytD2F\">table2</a> demo test demo test demo test demo test demo test demo test demo test demo test demo test demo test </p>"
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.