using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[(?:[^[\]]|(?R))*\]|\((?:[^()]|(?R))*\))";
string input = @"[test1[test11]](test1(test11)) thisbitshouldnotmatch [test2[test222[test222]]test222](test2)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}