package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\[(?:[^[\]]|(?R))*\]|\((?:[^()]|(?R))*\))`)
var str = `[test1[test11]](test1(test11)) thisbitshouldnotmatch [test2[test222[test222]]test222](test2)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}