// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\[(?:[^[\]]|(?R))*\]|\((?:[^()]|(?R))*\))").unwrap();
let string = "[test1[test11]](test1(test11)) thisbitshouldnotmatch [test2[test222[test222]]test222](test2)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}