re = /(?:\[(?:[^[\]]|(?R))*\]|\((?:[^()]|(?R))*\))/
str = '[test1[test11]](test1(test11)) thisbitshouldnotmatch [test2[test222[test222]]test222](test2)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end