$re = '/(?:\[(?:[^[\]]|(?R))*\]|\((?:[^()]|(?R))*\))/';
$str = '[test1[test11]](test1(test11)) thisbitshouldnotmatch [test2[test222[test222]]test222](test2)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);