import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\[(?:[^[\\]]|(?R))*\\]|\\((?:[^()]|(?R))*\\))";
final String string = "[test1[test11]](test1(test11)) thisbitshouldnotmatch [test2[test222[test222]]test222](test2)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}