package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"empRef\":\"(?<empRef>[^\"]*)\"`)
var str = `[{"friendlyName":"","empRef":"012/AB00000"},{"friendlyName":"","empRef":"023/AB11111"}]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}