import Foundation
let pattern = #"\"empRef\":\"(?<empRef>[^\"]*)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[{"friendlyName":"","empRef":"012/AB00000"},{"friendlyName":"","empRef":"023/AB11111"}]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}