re = /\"empRef\":\"(?<empRef>[^\"]*)\"/
str = '[{"friendlyName":"","empRef":"012/AB00000"},{"friendlyName":"","empRef":"023/AB11111"}]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end