const regex = /\"empRef\":\"(?<empRef>[^\"]*)\"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"empRef\\":\\"(?<empRef>[^\\"]*)\\"', '')
const str = `[{"friendlyName":"","empRef":"012/AB00000"},{"friendlyName":"","empRef":"023/AB11111"}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}